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Basics

About the BlackBerry Desktop Software
The BlackBerry Desktop Software is designed to link the data, media files, and applications on your BlackBerry 
smartphone or your BlackBerry PlayBook tablet with your computer.

You can use the BlackBerry Desktop Software to do the following tasks with your smartphone or tablet:

• Synchronize your media files (music, pictures, and videos)
• Back up and restore your data
• Update your BlackBerry Device Software or BlackBerry Tablet OS
• Transfer your settings and data to a new smartphone or new tablet
• Manage multiple smartphones and tablets
• Charge your smartphone or tablet

Additionally, you can do the following tasks with your smartphone:

• Synchronize your organizer data (calendar entries, contacts, tasks, and memos)
• Manage and update your smartphone applications
• Use your smartphone as a modem to connect to the Internet from your computer

Features that aren't supported for the tablet won't appear on the BlackBerry Desktop Software screens when your tablet is 
connected.

The first time you open the BlackBerry Desktop Software, you're prompted to set some preferences, like starting the 
software when you connect your smartphone or tablet and automatically checking for software updates.

The home screen of the BlackBerry Desktop Software provides you with quick access to common tasks and provides 
information about your connected smartphone or tablet, such as the model information and the last dates that your data 
was backed up and synchronized. If you have used the BlackBerry Desktop Software with other smartphones or tablets, 
you can connect these smartphones or tablets and switch between them using the Device menu.
Related information
Set up your smartphone with the BlackBerry Desktop Software, 8
Set up your tablet with the BlackBerry Desktop Software, 9
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Set up your smartphone with the 
BlackBerry Desktop Software
The first time that you connect your BlackBerry smartphone to your computer and use the BlackBerry Desktop Software, 
the BlackBerry Desktop Software prompts you to set up your smartphone. You can change these settings at any time by 
clicking Device > Device options.

1. On your computer, open the BlackBerry Desktop Software.

2. Connect your smartphone to your computer. If prompted, click Yes to make this smartphone the active smartphone.

• To start using this smartphone, click Get started with this device.

• To switch from an existing smartphone, click Copy data and settings from another device. Follow the instructions 
on the screen to move your data to your new smartphone.

3. If your smartphone is associated with a BlackBerry Enterprise Server, do one of the following:

• To use your corporate email account and email address, click Add my enterprise email account. Follow the 
instructions on the screen to associate your smartphone with your corporate email account that is on your 
computer.

• To use a different email account, click Don't add the account.

4. Type a name for your smartphone. This name is displayed in the BlackBerry Desktop Software on the home screen 
and in the Device menu.

5. To start certain tasks automatically each time that you connect your smartphone, do any of the following:

• To back up your smartphone data and settings, select the Back up my device checkbox. In the drop-down list, 
select how often you want to back up your smartphone data and settings.

• To synchronize your calendar entries, contacts, memos, and tasks, select the Organizer data checkbox.

• To synchronize your songs, pictures, and videos, select the Media files checkbox.

• To keep your smartphone time synchronized with your computer, select the My computer's date and time with 
my device checkbox.

6. If you want to synchronize your music, in the Media settings section, select the music source for your music library.

7. If your smartphone includes built-in media storage and you want to save your media files to this storage location 
instead of a media card, in the Store media on drop-down list, click Device.

8. Click Finish.

After your smartphone is added, keep it connected to your computer so that the BlackBerry Desktop Software can check 
for updated software that might be available.
Related information
Remove your settings from the BlackBerry Desktop Software, 14
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My computer doesn't detect my smartphone or tablet, 15

Set up your tablet with the BlackBerry 
Desktop Software
The first time that you connect your BlackBerry PlayBook tablet to your computer and use the BlackBerry Desktop 
Software, the BlackBerry Desktop Software prompts you to set up your tablet. You can change these settings at any time by 
clicking Device > Device options.

1. On your computer, open the BlackBerry Desktop Software.

2. Connect your tablet to your computer. If prompted, click Yes to make this tablet the active tablet.

• To start using this tablet, click Get started with this device.

• To switch from an existing tablet, click Copy data and settings from another device. Follow the instructions on 
the screen to move your data to your new tablet.

3. Type a name for your tablet. This name is displayed on the home screen of the BlackBerry Desktop Software and in 
the Device menu.

4. To start certain tasks automatically each time that you connect your tablet, do any of the following:

• To back up your tablet data and settings, select the Back up my device checkbox. In the drop-down list, select 
how often you want to back up your tablet data and settings.

• To synchronize your songs, pictures, and videos, select the Media files checkbox.

5. If you want to synchronize your music, in the Media settings section, select the music source for your music library.

6. Click Finish.

After your tablet is added, keep it connected to your computer so that the BlackBerry Desktop Software can check for 
updated software that might be available.
Related information
Remove your settings from the BlackBerry Desktop Software, 14
My computer doesn't detect my smartphone or tablet, 15
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Activate your smartphone with a 
BlackBerry Enterprise Server

Activate your smartphone with BlackBerry Enterprise 
Server for Microsoft Exchange Server
If your BlackBerry smartphone is associated with a BlackBerry Enterprise Server, you can activate your smartphone to 
access your corporate email account.

You can also activate your smartphone with the BlackBerry Enterprise Server when you set up your smartphone with the 
BlackBerry Desktop Software. If you use the BlackBerry Desktop Software to switch to a new BlackBerry smartphone, your 
activation settings are copied to your new smartphone.

For more information about the following settings, contact your administrator.

1. Connect your smartphone to your computer that is part of your corporate network.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Enterprise Email tab, in the Email system drop-down list, click Microsoft Exchange (Outlook Client).

4. Do one of the following:

• If you haven't selected a profile for Microsoft Outlook, select one in the Profile Options window when you're 
prompted.

• If you have selected a profile and you want to change it, click Change to browse for a different profile.

5. Do any of the following optional steps:

• To add the name of your email account on your smartphone, type the name in the Service name field.

• To include a signature in your outgoing email messages, type a signature in the Email signature field.

• To save copies of the email messages from your smartphone to the Sent Items folder in your Microsoft Outlook 
email account, select the Save sent emails checkbox.

6. Click OK.
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Activate your smartphone with BlackBerry Enterprise 
Server for IBM Lotus Notes
If your BlackBerry smartphone is associated with a BlackBerry Enterprise Server, you can activate your smartphone to 
access your corporate email account.

You can also activate your smartphone with the BlackBerry Enterprise Server when you set up your smartphone with the 
BlackBerry Desktop Software. If you use the BlackBerry Desktop Software to switch to a new BlackBerry smartphone, your 
activation settings are copied to your new smartphone.

For more information about the following settings, contact your administrator.

1. Connect your smartphone to your computer that is part of your corporate network.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Enterprise Email tab, in the Email system drop-down list, click Microsoft Exchange (Outlook Client).

4. Do one of the following:

• If you haven't selected a server, click Select server > IBM Lotus Domino.

• If you have selected a server and you want to change it, click Change to browse for a different server.

5. Do any of the following optional steps:

• To add the name of your email account on your smartphone, type the name in the Service name field.

• To include a signature in your outgoing email messages, type a signature in the Email signature field.

• To save copies of the email messages from your smartphone to the Sent Mail folder in your IBM Lotus Notes email 
account, select the Save sent emails checkbox.

6. Click OK.

Prerequisites: Bluetooth connections
• Verify that your BlackBerry smartphone is running BlackBerry Device Software 4.1 or later.
• Verify that your computer is running Windows XP SP 3 or later. For more information about the Bluetooth adapters that 

are supported in Windows XP SP 3 or later, visit www.blackberry.com/support.
• If your smartphone is not paired with your computer, on your smartphone, verify that Bluetooth technology is turned on. 

For more information about pairing, click Help on your smartphone.

Related information
Connect your smartphone to your computer using Bluetooth technology, 12
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Connect your smartphone to your 
computer using Bluetooth technology
If you don't want to connect your BlackBerry smartphone to your computer with a USB cable, you can connect using 
Bluetooth technology. If you're using Bluetooth technology to connect to your computer, you cannot update your 
smartphone software, add, update, or delete your applications or media files, or switch smartphones using the BlackBerry 
Desktop Software.

1. In the BlackBerry Desktop Software, click Tools > Add Bluetooth device.

2. Do one of the following:

• If your smartphone is paired with your computer, in the Bluetooth® Devices window, click your smartphone. Click 
OK.

• If your smartphone isn't paired with your computer, click Add. Click a smartphone with Bluetooth connectivity 
turned on. Click OK. Follow the prompts to pair your smartphone. After the smartphone is paired, in the 
Bluetooth® Devices window, click your smartphone. Click OK.

3. Click OK.

Start tasks automatically when you connect 
your smartphone
You can set certain BlackBerry Desktop Software tasks to start when you connect your BlackBerry smartphone to your 
computer.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the General tab, in the When I connect my device section, do any of the following:

• To back up your smartphone data and settings, select the Back up my device checkbox. In the drop-down list, 
click how often you want to back up your smartphone data and settings.

• To synchronize your calendar entries, contacts, memos, and tasks, select the Organizer data checkbox.

• To synchronize your songs, pictures, and videos, select the Media files checkbox.
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• To keep the date and time on your smartphone synchronized with the date and time on your computer, select the 
My computer's date and time with my device checkbox.

• If you have certificate synchronization turned on and you want to synchronize certificates, select the Certificates 
checkbox. To specify an interval to synchronize your certificates again during the same BlackBerry Desktop 
Software session, select the Re-synchronize periodically (hours) checkbox. In the drop-down list, click an 
interval.

4. Click OK.

Related information
Turn off automatic initialization of the random number generator, 44

Delete the data from your smartphone
Before you delete the data from your BlackBerry smartphone, consider backing up your data so that you have a copy on 
your computer. If you have turned on encryption, the process for deleting all smartphone data can take up to an hour to 
complete.

CAUTION: You can't stop the process for deleting all data after you start it. If you reset your smartphone, the process 
continues after the smartphone restarts.

Research In Motion recommends that you regularly create and save a backup file on your computer, especially before you 
update any software. Maintaining a current backup file on your computer might allow you to recover smartphone data if 
your smartphone is lost, stolen, or corrupted by an unforeseen issue.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Delete data.

• To delete all your smartphone data, click All data.

• To delete specific data, click Selected data. Select the checkbox beside one or more types of data

3. If necessary, do any of the following:

• If your smartphone includes built-in media storage, select the Delete files saved on my device's built-in media 
storage checkbox.

• To create a backup file for your smartphone data, select the Back up data before deleting checkbox. To encrypt 
the backup file, select the Encrypt backup file checkbox. Type a password.

4. Click Delete.
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Reset the BlackBerry Desktop Software 
settings
You can reset all the settings in the BlackBerry Desktop Software to the default settings.

1. Connect your BlackBerry device to your computer.

2. In the BlackBerry Desktop Software, click Tools > Desktop options.

3. On the General tab or Bluetooth tab, click Restore default settings.

4. To revert any settings that you might have changed for the BlackBerry Desktop Software, click the Desktop options 
and settings checkbox.

5. To receive message prompts again that you previously chose to stop receiving, click the "Don't show this message 
again" prompts checkbox.

6. Click Restore.

Remove your settings from the BlackBerry 
Desktop Software
If you want to stop associating your BlackBerry smartphone or BlackBerry PlayBook tablet with the BlackBerry Desktop 
Software that is installed on your computer, you can remove your current settings.

1. On your computer, open the BlackBerry Desktop Software.

2. In the Device menu, click the name of your smartphone or tablet.

3. Click Device > Forget device > Forget.

If you want to reassociate your smartphone or tablet with the BlackBerry Desktop Software, connect your device to your 
computer and complete the steps to add a new smartphone or new tablet.
Related information
Set up your smartphone with the BlackBerry Desktop Software, 8 
Set up your tablet with the BlackBerry Desktop Software, 9 
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Check for BlackBerry Desktop Software 
updates
To perform this task, you must have an active Internet connection.

1. In the BlackBerry Desktop Software, click Help > Check for updates.

2. If an update is available, review the information on the screen and if you want to install it, click Get update.

3. After the update is downloaded, close the BlackBerry Desktop Software when you are prompted to.

4. Open the BlackBerry Desktop Software again to complete the installation.

5. Click Close when the update is complete.

You might need to restart your computer after the update is installed.

Find more information
You can visit the following websites for more information about the BlackBerry Desktop Software:

• http://na.blackberry.com/eng/support/software/desktop.jsp: View support information, including Knowledge Base 
articles and forums.

• www.blackberry.com/desktop/docs: View the latest help associated with this release.
• http://docs.blackberry.com: Find the latest user guide for your BlackBerry device or click Help on your device.
• www.blackberry.com/desktop: Download the latest version of the BlackBerry Desktop Software.

Troubleshooting: Basics

My computer doesn't detect my smartphone or tablet
If your computer doesn't detect your BlackBerry smartphone, try the following:
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• If you're using a USB cable to connect your smartphone to your computer, verify that the USB cable isn't damaged. If it 
isn't damaged, disconnect and reconnect the USB cable.

• If you're using Bluetooth technology to connect your smartphone to your computer, verify that the Bluetooth 
connection is turned on and your smartphone is paired with your computer. Verify that your smartphone is within range 
of your computer (a typical range is approximately 10 m).

• Verify that your smartphone is charged.
• Verify that mass storage mode is turned on.
• Verify that you have a media card or built-in media storage.
• If your smartphone is running BlackBerry 6 or later and Wi-Fi music sync is turned on, verify that your smartphone is 

connected to the same Wi-Fi network as your computer.
• On your computer, turn off synchronization applications or antivirus applications temporarily.

If your computer doesn't detect your BlackBerry PlayBook tablet, try the following:

• If you're using a USB cable to connect your tablet to your computer, verify that the USB cable isn't damaged. If it isn't 
damaged, disconnect and reconnect the USB cable.

• Verify that your tablet is charged.
• On your computer, turn off synchronization applications or antivirus applications temporarily.
• If your computer is running Windows XP x64 Edition and your computer's certification authority does not support 

SHA2-256 encryption, you must download a hotfix from Microsoft. For more information, visit 
www.support.microsoft.com to read article 968730.

Related information
Set up your smartphone with the BlackBerry Desktop Software, 8 
Set up your tablet with the BlackBerry Desktop Software, 9 
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Backup and restore

About backing up and restoring data
You can back up and restore most of the data on your BlackBerry smartphone and BlackBerry PlayBook tablet, including 
settings, fonts, saved searches, and browser bookmarks.

If you're using a smartphone, you can also back up your messages and organizer data.

If you're using a tablet, you can also back up your media files.

Research In Motion recommends that you regularly create and save a backup file on your computer, especially before you 
update any software. Maintaining an up-to-date backup file on your computer might allow you to recover smartphone data 
or tablet data if your smartphone or tablet is lost, stolen, or corrupted by an unforeseen issue.

By default, the BlackBerry Desktop Software saves your backup files to My Documents/BlackBerry/Backup on your 
computer.

Back up smartphone data or tablet data
Before you begin: If you're using a BlackBerry smartphone that includes built-in media storage, mass storage mode must 
be turned on.

1. Connect your smartphone or BlackBerry PlayBook tablet to your computer.

2. In the BlackBerry Desktop Software, click Device > Back up.

3. Do one of the following:

• To back up all your smartphone data or tablet data, click Full (all device data and settings).

• To back up all your smartphone data except for email messages, click Quick (exclude email).

• To select which types of smartphone data or tablet data to back up, click Custom (selected data only). Select the 
checkbox next to the data you want to back up.

4. If your smartphone includes built-in media storage and you want to back up data that is stored there, select the Files 
saved on my built-in media storage checkbox.

5. Do any of the following:

• To change the default name for the backup file, in the File name field, type a new name.

• To change the folder where the BlackBerry Desktop Software saves your backup files, click Change > Yes. Browse 
to a folder and click OK.
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• To encrypt your data, select the Encrypt backup file checkbox. Type a password.

• To save your settings so that you aren't prompted to set these options again when you back up your smartphone 
or tablet, select the Don't ask for these settings again checkbox.

6. Click Back up.

Restore smartphone data or tablet data
Before you begin: If you're using a BlackBerry smartphone that includes built-in media storage, mass storage mode must 
be turned on to restore your smartphone data.

CAUTION: When you restore data to your smartphone or BlackBerry PlayBook tablet, all files that are stored on your 
smartphone or tablet are deleted before the backup file is restored. If there is data on your smartphone or tablet that is not 
in the backup file, this data will be lost.

1. Connect your smartphone or tablet to your computer.

2. In the BlackBerry Desktop Software, click Device > Restore.

3. Do one of the following:

• Select a backup file that contains the data you want to restore.

• If you don't see the backup file you want to restore, click Change. Browse to the folder containing the backup file.

4. Do one of the following:

• To restore all your smartphone data or tablet data, click All device data and settings.

• To select which smartphone data or tablet data you want to restore, click Select device data and settings. Select 
the checkbox beside the data type that you want to restore.

• If your smartphone includes built-in media storage, and you want restore it, select the Files saved on my built-in 
media storage checkbox.

5. If the backup file is encrypted, type the password that you set to encrypt.

6. Click Restore.

Change the location of backup files on your 
computer
By default, the BlackBerry Desktop Software saves your backup files to C:\My Documents\BlackBerry\Backup on your 
computer.
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1. In the BlackBerry Desktop Software, click Device > Back up.

2. In the File Options section, click Change > Yes.

3. Browse to a folder and click OK.

Troubleshooting: Backup and restore

I can't restore a backup file to my smartphone or 
tablet
If you create a backup file on a smartphone that is running BlackBerry 7 or later or a BlackBerry PlayBook tablet that is 
running BlackBerry PlayBook OS 2.0, the backup file is associated with the BlackBerry ID on the device. You cannot 
restore a backup file to a device that has a different BlackBerry ID.

Try changing the BlackBerry ID on your device to the BlackBerry ID associated with the backup file.

1. Disconnect your device from your computer.
2. From your device, delete all of the device data. (For more information about how to delete data and third-party 

applications, see the help on your device.)
3. Complete the setup process for your device and configure the BlackBerry ID user name that was used to create the 

backup file.
4. Connect your device to your computer. Open the BlackBerry Desktop Software and try to restore the backup file to the 

device again.

If you still cannot restore the backup file to your device, or if your backup file was created on a smartphone running 
BlackBerry 6 or earlier or a tablet with the BlackBerry Tablet OS 1.0 installed on it, your backup file might be corrupted. 
You can't restore a corrupted backup file to your smartphone or tablet. Try restoring a different backup file.
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Organizer data

About synchronizing your organizer data
You can synchronize your organizer data between your BlackBerry smartphone and your computer to keep the data the 
same in both locations. When you make changes, you can synchronize data again to keep your data up-to-date.

If wireless synchronization is not available for your smartphone, or you have turned it off, you can synchronize your 
organizer data using the BlackBerry Desktop Software instead of over the wireless network. You can turn off wireless 
synchronization for each organizer application on your smartphone. This feature isn't available for the BlackBerry® 

PlayBook™ tablet.

Organizer data includes your calendar entries, contacts, tasks, and memos. You can set options for each type of data, such 
as the application that you use on your computer for your organizer data and how you want to synchronize your data.

Prerequisites: Organizer data 
synchronization
• To synchronize organizer data, verify that you have configured options for your calendar, contacts, tasks, or memos in 

the BlackBerry Desktop Software.
• If wireless data synchronization is available for your BlackBerry smartphone, but you want to synchronize your 

organizer data using the BlackBerry Desktop Software, verify that wireless synchronization is turned off on your 
smartphone. For more information about wireless synchronization, click Help on your smartphone.

Related information
Turn off wireless synchronization on your smartphone, 21
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Turn off wireless synchronization on your 
smartphone
To synchronize your organizer data, you must turn off wireless synchronization on your BlackBerry smartphone for each 
type of organizer data that you want to synchronize using the BlackBerry Desktop Software.

1. On your smartphone, in the Calendar application, Contacts application, Tasks application, or MemoPad, press the 
Menu key > Options.

2. If necessary, click a calendar or contact list.

3. Change the Wireless Synchronization field to No or clear the Wireless Synchronization checkbox.

4. Press the Menu key > Save.

Related information
Prerequisites: Organizer data synchronization, 20 
Synchronize your organizer data, 27

Configure your contact synchronization 
options
Before you can synchronize your contacts between your BlackBerry smartphone and your computer, you need to configure 
your synchronization options.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer.

3. Click Configure beside Contacts.

4. In the Sync direction drop-down list, do one of the following:

• To keep contact entries the same on your smartphone and your computer, click Two way between your device 
and computer.

• To synchronize updates to the contact entries from your computer to your smartphone, click One way to your 
device only. To replace all entries on your smartphone with the entries on your computer, select the Replace all 
entries on your device with the entries on your computer checkbox.
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• To synchronize updates to the contact entries from your smartphone to your computer, click One way to your 
computer only. To replace all entries on your computer with the entries on your smartphone, select the Replace 
all entries on your computer with the entries on your device checkbox.

5. In the Account Settings section, in the Contacts account drop-down list, click the contacts application that you use 
on your computer.

6. Click Configure. Do one of the following:

• If you use Microsoft Outlook, in the Outlook Profile drop-down list, click your profile.

• If you use IBM Lotus Notes, click Browse to select your .ini file. If necessary, type your password. If you don't want 
to be prompted for a password, clear the Prompt at every sync checkbox.

7. Click Close > OK.

To go back to the default options for all of your organizer data, in the BlackBerry Desktop Software, click Organizer > Reset 
settings.
Related information
Create filters to limit the organizer data synchronized between your smartphone and your computer, 25
Customize the fields that synchronize between your smartphone and your computer, 26
Configure synchronization of a secondary collection of organizer data, 26
Synchronize your organizer data, 27

Configure your calendar synchronization 
options
Before you can synchronize your calendar entries between your BlackBerry smartphone and your computer, you need to 
configure your synchronization options.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer.

3. Click Configure beside Calendar.

4. In the Sync direction drop-down list, do one of the following:

• To keep calendar entries the same on your smartphone and your computer, click Two way between your device 
and computer.

• To synchronize updates to the calendar entries from your computer to your smartphone, click One way to your 
device only. To replace all entries on your smartphone with the entries on your computer, select the Replace all 
entries on your device with the entries on your computer checkbox.

• To synchronize updates to the calendar entries from your smartphone to your computer, click One way to your 
computer only. To replace all entries on your computer with the entries on your smartphone, select the Replace 
all entries on your computer with the entries on your device checkbox.
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5. If you don't want to synchronize calendar entries that have already passed, select the Only sync future entries 
checkbox.

6. In the Account Settings section, in the Calendar account drop-down list, click the calendar application that you use 
on your computer.

7. Click Configure. Do one of the following:

• If you use the calendar application for Windows Vista or Windows 7, click Browse to select the location of your 
Calendars file.

• If you use Microsoft Outlook, in the Outlook Profile drop-down list, click your profile.

• If you use IBM Lotus Notes, click Browse to select your .ini file. If necessary, type your password. If you don't want 
to be prompted for a password, clear the Prompt at every sync checkbox.

8. Click Close > OK.

To go back to the default options for all of your organizer data, in the BlackBerry Desktop Software, click Organizer > Reset 
settings.
Related information
Create filters to limit the organizer data synchronized between your smartphone and your computer, 25
Customize the fields that synchronize between your smartphone and your computer, 26
Configure synchronization of a secondary collection of organizer data, 26
Synchronize your organizer data, 27

Configure your memo synchronization 
options
Before you can synchronize your memos between your BlackBerry smartphone and your computer, you need to configure 
your synchronization options.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer.

3. Click Configure beside Memos.

4. In the Sync direction drop-down list, do one of the following:

• To keep memo entries the same on your smartphone and your computer, click Two way between your device and 
computer.

• To synchronize updates to the memo entries from your computer to your smartphone, click One way to your 
device only. To replace all entries on your smartphone with the entries on your computer, select the Replace all 
entries on your device with the entries on your computer checkbox.
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• To synchronize updates to the memo entries from your smartphone to your computer, click One way to your 
computer only. To replace all entries on your computer with the entries on your smartphone, select the Replace 
all entries on your computer with the entries on your device checkbox.

5. In the Account Settings section, in the Memos account drop-down list, click the memo application that you use on 
your computer.

6. Click Configure. Do one of the following:

• If you use Microsoft Outlook, in the Outlook Profile drop-down list, click your profile.

• If you use IBM Lotus Notes, click Browse to select your .ini file. If necessary, type your password. If you don't want 
to be prompted for a password, clear the Prompt at every sync checkbox.

7. Click Close > OK.

To go back to the default options for all of your organizer data, in the BlackBerry Desktop Software, click Organizer > Reset 
settings.
Related information
Create filters to limit the organizer data synchronized between your smartphone and your computer, 25
Customize the fields that synchronize between your smartphone and your computer, 26
Configure synchronization of a secondary collection of organizer data, 26
Synchronize your organizer data, 27

Configure your task synchronization 
options
Before you can synchronize your tasks between your BlackBerry smartphone and your computer, you need to configure 
your synchronization options.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer.

3. Click Configure beside Tasks.

4. In the Sync direction drop-down list, do one of the following:

• To keep task entries the same on your smartphone and your computer, click Two way between your device and 
computer.

• To synchronize updates to the task entries from your computer to your smartphone, click One way to your device 
only. To replace all entries on your smartphone with the entries on your computer, select the Replace all entries 
on your device with the entries on your computer checkbox.

• To synchronize updates to the task entries from your smartphone to your computer, click One way to your 
computer only. To replace all entries on your computer with the entries on your smartphone, select the Replace 
all entries on your computer with the entries on your device checkbox.
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5. If you don't want to synchronize tasks that have already passed, select Upcoming tasks only.

6. In the Account Settings section, in the Tasks account drop-down list, click the calendar application that you use on 
your computer.

7. Click Configure. Do one of the following:

• If you use Microsoft Outlook, in the Outlook Profile drop-down list, click your profile.

• If you use IBM Lotus Notes, click Browse to select your .ini file. If necessary, type your password. If you don't want 
to be prompted for a password, clear the Prompt at every sync checkbox.

8. Click Close > OK.

To go back to the default options for all of your organizer data, in the BlackBerry Desktop Software, click Organizer > Reset 
settings.
Related information
Create filters to limit the organizer data synchronized between your smartphone and your computer, 25
Customize the fields that synchronize between your smartphone and your computer, 26
Configure synchronization of a secondary collection of organizer data, 26
Synchronize your organizer data, 27

Create filters to limit the organizer data 
synchronized between your smartphone 
and your computer
You can set conditions to limit the organizer data that is synchronized between your BlackBerry smartphone and your 
computer. Before you can create a filter, you must configure synchronization options for your contacts, calendars, memos, 
and tasks.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer.

3. Click Configure beside the organizer data type.

4. Click Advanced.

5. On the Filters tab, do one of the following:

• To limit data that meets all filter conditions, click All of the following conditions.

• To limit data that meets one or more of the filter conditions, click Any of the following conditions.

6. Select the organizer data entry field that you want to apply the filter to.

7. Select the operator that specifies the condition of the filter.

8. Select the date or text to filter.
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9. To create an additional filter, click the + icon.

10. Click OK > OK.

Customize the fields that synchronize 
between your smartphone and your 
computer
You can customize the BlackBerry smartphone fields that synchronize between your smartphone and the organizer data 
application on your computer. Some fields are already mapped between your smartphone and your computer. Before you 
can complete this task, you must configure synchronization options for your contacts, calendars, memos, and tasks.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer.

3. Click Configure beside the organizer data type.

4. Click Advanced.

5. To synchronize additional fields or to change the current field mapping, on the Fields tab, do any of the following:

• In the Device Field column, select the checkbox beside the smartphone field that you want to synchronize.

• In the <Application> Field column, in the drop-down list, click the field that you want the smartphone field to 
correspond to.

6. To stop synchronizing a field, in the Device Field column, clear the checkbox beside the appropriate field. Fields that 
can't be unmapped are dimmed.

7. Click OK > OK.

Configure synchronization of a secondary 
collection of organizer data
If you don't want to synchronize your primary contact list, calendar, memos, or tasks from your computer to your 
BlackBerry smartphone, you can choose to synchronize a different collection of organizer data. For example, you might 
want to synchronize events from a calendar other than the main calendar on your computer. Before you can complete this 
task, you must configure synchronization options for your contacts, calendars, memos, and tasks.
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1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer.

3. Click Configure beside the organizer data type.

4. Click Advanced.

5. On the Folders tab, click Select different <organizer data type> to sync.

6. Highlight the contacts application, calendar, memo folder, or task folder, and navigate to the correct folder. Click 
Add.

7. Click OK > OK.

Synchronize your organizer data
Before you begin: To perform this task, you must first set up organizer data synchronization. Also, on your BlackBerry 
smartphone, wireless synchronization must be turned off for each type of organizer data that you want to synchronize.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer.

3. Review the organizer applications and settings that are selected for synchronization and, if necessary, make changes.

4. Click Sync Organizer.

Related information
Turn off wireless synchronization on your smartphone, 21 
Troubleshooting: Organizer data synchronization, 29
Configure your contact synchronization options, 21 
Configure your calendar synchronization options, 22 
Configure your memo synchronization options, 23 
Configure your task synchronization options, 24 

Change your conflict notification
If there are conflicts between the data on your BlackBerry smartphone and the data on your computer, you can choose 
how you want to handle these conflicts and how often you want to be notified.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer > Organizer options.

3. In the Conflicts section, click a notification method.
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4. Click OK.

Receive a prompt to confirm your 
synchronization changes
If you make changes to your synchronization options for organizer data, you can choose to receive a prompt to confirm the 
changes before the options take effect.

1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Organizer > Organizer options.

3. In the Confirm Your Changes section, do one of the following:

• To receive a confirmation and details for all synchronization changes, select Confirm any changes.

• To receive a confirmation before deleting an entry, select Only confirm when deleting entries.

• To synchronize your organizer data without any confirmation, select Don’t ask for confirmation.

4. Click OK.

Save log files to your computer
You can save log files when you synchronize your organizer data or complete other tasks in the BlackBerry Desktop 
Software. You can use these log files to troubleshoot possible issues you might encounter or you can send the files to a 
technical support representative.

1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Tools > Desktop options.

3. Click the Configure sync logging options link.

4. In the Logging method drop-down list, do one of the following:

• To save a log file that only contains your synchronization information, select Basic (sync data only).

• To save a log file that contains your synchronization information and all details about your usage of the BlackBerry 
Desktop Software, including personal information, select Full.

5. In the Keep log files for this many days drop-down list, click the number of days you want to keep your log files.

6. Click OK.

User Guide Organizer data 

28 



Troubleshooting: Organizer data 
synchronization

I receive a message that my default services have 
changed
When you synchronize your organizer data using the BlackBerry Desktop Software, you might receive a message that your 
default services on your BlackBerry smartphone have changed if you recently added a new email address to your 
smartphone, for example. Your default services are associated with your Calendar application, Contacts application, and 
Messages application, and might change depending on the applications on your smartphone.

When you receive the message, you can do one of the following:

• To return to your default services that were available the last time that you synchronized your data, click Yes. This 
action does not change the default services on your smartphone.

• To start using your new default service, which might duplicate some data entries if these entries already exist from 
another service, click No.

• To cancel the synchronization and review your default services settings for your smartphone, click Cancel.

If your smartphone is running BlackBerry Device Software 4.7.1 or earlier, you can only continue or stop the 
synchronization from the message.

I can't synchronize my data to other calendars on my 
computer
If you have more than one calendar on your BlackBerry smartphone, for example, a personal calendar from an email 
account and a work calendar that is associated with a BlackBerry Enterprise Server, your smartphone is still set up to 
synchronize only one smartphone calendar to your computer.

To change the calendar that is being used on your computer for synchronization, in the BlackBerry Desktop Software, click 
Organizer. Click Configure beside Calendar. Change your calendar application.

To change the calendar that is being used on your smartphone for synchronization, you must change the default calendar 
on your smartphone. For more information about how to change your default calendar, click the Help icon on the home 
screen of your smartphone.
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Some calendar entries are missing from my computer 
after synchronization
If you have more than one calendar on your BlackBerry smartphone, you see a combined view of these calendar entries on 
your smartphone by default.

You can only synchronize entries from one calendar on your smartphone to one calendar on your computer at a time. Some 
entries might be missing from your computer because they belong to a different calendar on your smartphone that is not 
set up to synchronize with the calendar on your computer.

To change the calendar that is being used on your smartphone for synchronization, you must change the default calendar 
on your smartphone. For more information about how to change your default calendar, click the Help icon on the home 
screen of your smartphone.

Some organizer data doesn't appear on my 
smartphone after synchronization
You might need to verify your synchronization options. In the BlackBerry Desktop Software, click Organizer. Try the 
following actions:

• Check the conflict resolution options for the organizer data that isn't appearing. Click Organizer options. In the 
Conflicts section, verify that the Don't sync conflicting data option isn't selected.

• If some tasks aren't appearing on your BlackBerry smartphone, click Configure beside Tasks. Verify that the All tasks 
option is selected.

• If some calendar entries aren't appearing on your smartphone, verify that these calendar entries aren't appointments 
and meetings that you manage for someone else. If you use Microsoft Outlook to manage someone else's calendar, that 
person's appointments and meetings don't appear on your smartphone.

Duplicate organizer data fields appear on my 
smartphone after synchronization
You might need to verify your synchronization options. In the BlackBerry Desktop Software, click Organizer. Try the 
following actions:

• Click Organizer options. In the Conflicts section, verify that the Create separate entries for conflicting data option and 
Don't sync conflicting data option are not selected.
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• For each organizer application, click Configure > Advanced. On the Fields tab, verify that the field mapping for each 
organizer application is correct.

• Beside Contacts, click Configure > Advanced. On the Fields tab, verify that both the First Name field and Middle 
Name field in your organizer application are mapped to the First Name field on your BlackBerry smartphone.

I'm not notified when there is a conflict during 
synchronization
In the BlackBerry Desktop Software, click Organizer > Organizer options. In the Conflicts section, verify that the Notify me 
when there are conflicts option is selected.

Organizer data is cut off after synchronization
During synchronization, data that is too long, for example, long descriptions in calendar entries, might be cut off.

If you do not want data that is cut off to replace existing data during synchronization, in the BlackBerry Desktop Software, 
click Organizer > Organizer options. In the Conflicts section, verify that the Notify me when there are conflicts option is 
selected.

Synchronization stopped unexpectedly
If you are running an antivirus application on your computer, close the application temporarily and try synchronizing again.

User Guide Organizer data 

31 



Applications

About applications
Applications help you get the most benefit, value, and fun out of your BlackBerry smartphone.

When your smartphone is connected to your computer, the Applications screen in the BlackBerry Desktop Software lists 
applications that are currently on your smartphone and lists any new or updated applications that are available for you to 
add. This feature isn't available for the BlackBerry® PlayBook™ tablet.

If your smartphone is connected to your computer using Bluetooth technology, you cannot add, update, or delete your 
applications on your smartphone using the BlackBerry Desktop Software.

Add, update, or delete applications on your 
smartphone
You can add, update, or delete applications on your BlackBerry smartphone using the Applications screen in the 
BlackBerry Desktop Software. When you connect your smartphone to your computer, your smartphone is scanned and the 
applications are listed in the Applications pane.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Applications.

3. When your smartphone applications are listed, do any of the following:

• To update an application, click the + icon beside the name of the application.

• To delete an application, click the x icon beside the name of the application.

• To install an application file (.alx) that is saved on your computer, click Import files to browse to it.

4. In the Application Summary pane, review your changes.

5. Click Apply.

Related information
I cannot add, update, or delete smartphone applications, 33
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Add a display language to your smartphone
You can add a new language to your BlackBerry smartphone if your BlackBerry Device Software supports multiple 
languages.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Applications.

3. Expand the BlackBerry <version> Core Applications section.

4. In the Language and Input Support section, click the + icon for the language that you want to add to your 
smartphone.

5. Click Apply.

Troubleshooting: Applications

I cannot add, update, or delete smartphone 
applications
If your BlackBerry smartphone is associated with an email account that uses a BlackBerry Enterprise Server, your 
organization might not permit you to add, update, or delete smartphone applications. For more information, contact your 
administrator.
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Software updates

Update your BlackBerry Device Software
You might want to update your BlackBerry Device Software for one of the following reasons:

• To access new applications and features
• To resolve a technical issue
• Your wireless service provider requires that you update the BlackBerry Device Software

If an updated version of the BlackBerry Device Software is available for you to download, on the home screen of the 
BlackBerry Desktop Software, the new version number is listed and the Update button appears.

It might take up to an hour to update your smartphone software. During that time, you cannot disconnect your BlackBerry 
smartphone from your computer.

1. Connect your smartphone to your computer.

2. On the home screen of the BlackBerry Desktop Software, click Update.

• To download an update, click Get update.

• To view other available versions of the BlackBerry Device Software, click View other versions. If applicable, click 
another version. Click Install.

3. Do any of the following:

• To keep a backup file of your smartphone data and settings, select the Back up your device data checkbox. This 
backup file is restored to your smartphone after the update is complete. If you don't back up your data, your 
smartphone data, settings, and email messages are deleted from your smartphone after the update is installed.

• To encrypt your backup data, click Encrypt backup file.

• If you want to receive an email when an updated version of BlackBerry Device Software is available, select the 
Keep me subscribed to email notifications checkbox.

4. Click Install update.

When you receive a confirmation message that the update is complete, you can disconnect your smartphone.

Update your BlackBerry Tablet OS
You might want to update your BlackBerry Tablet OS for one of the following reasons:
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• To access new applications and features
• To resolve a technical issue

If an updated version of the BlackBerry Tablet OS is available for you to download, on the home screen of the BlackBerry 
Desktop Software, the new version number is listed and the Update button appears.

It might take up to an hour to update your tablet software. During that time, you cannot disconnect your BlackBerry 
PlayBook tablet from your computer.

1. Connect your tablet to your computer.

2. On the home screen of the BlackBerry Desktop Software, click Update.

• To download an update, click Get update.

• To view other available versions of the BlackBerry Tablet OS, click View other versions. If applicable, click 
another version. Click Install.

3. If you want to receive an email when an updated version of BlackBerry Tablet OS is available, select the Keep me 
subscribed to email notifications checkbox.

4. Click Install update.

When you receive a confirmation message that the update is complete, you can disconnect your tablet.

Receive notifications for software updates
If you sign up to receive notifications, when an updated version of the BlackBerry Device Software or BlackBerry Tablet OS 
becomes available, you are notified with an email.

1. Connect your BlackBerry smartphone or BlackBerry PlayBook tablet to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the General tab, select the Keep me subscribed to email notifications checkbox.

4. Type your email address.

5. Click OK.

To stop receiving the notifications, clear the Keep me subscribed to email notifications checkbox.
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Switch to a new smartphone or new 
tablet

About switching to a new smartphone or 
new tablet
If you want to start using a new BlackBerry smartphone, you can use the BlackBerry Desktop Software to move your 
current data and settings to your new smartphone. You can also use the BlackBerry Desktop Software to move your data 
and settings from an existing BlackBerry PlayBook tablet to a new tablet.

If you're switching from a BlackBerry smartphone, your data and settings, such as supported email messages, organizer 
data, and third-party applications that are compatible with your new smartphone, are imported to your new smartphone. If 
your email account is associated with a BlackBerry Enterprise Server, your email settings are also imported to your new 
smartphone.

If you're switching from a BlackBerry PlayBook tablet, your media files, application data, and settings are imported to your 
new tablet.

Switch to a new smartphone
Before you begin: Before you switch from your current BlackBerry smartphone to a new BlackBerry smartphone, verify 
that you have the most recent version of the BlackBerry Desktop Software on your computer.

1. Connect your current smartphone to your computer with a USB cable.

2. In the BlackBerry Desktop Software, click Device > Switch devices.

3. Click the icon for your current smartphone.

• To transfer your existing smartphone data to your new smartphone, select the Device data checkbox.

• To transfer any third-party applications that are compatible with your new smartphone, select the Third-party 
applications checkbox.

4. Click Next. Your smartphone data is backed up.

5. At the prompt, connect your new smartphone to your computer with a USB cable and click Next.

6. Click the icon for your new smartphone.
Your smartphone data is imported to your new smartphone.
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7. Move your SIM card and your media card (if you have one) to your new smartphone.

If you're switching from a smartphone that is associated with the BlackBerry Internet Service, on your new smartphone, in 
the setup wizard, open the email setup screen. Update your smartphone PIN.
Related information
Check for BlackBerry Desktop Software updates, 15 

Switch to a new tablet
Before you begin: Before you switch from your current BlackBerry PlayBook tablet to a new tablet, verify that you have the 
most recent version of the BlackBerry Desktop Software on your computer. You might be prompted to upgrade your 
BlackBerry Tablet OS.

1. Connect your current tablet to your computer with a USB cable.

2. In the BlackBerry Desktop Software, click Device > Switch devices.

3. Click the icon for your current tablet.

• To transfer your media files to your new tablet, including songs, pictures, and videos, select the Media files 
checkbox.

• To transfer your tablet settings and applications to your new tablet, select the Applications and settings 
checkbox.

4. Click Next. Your tablet data is backed up.

5. At the prompt, connect your new tablet to your computer with a USB cable and click Next.

6. Click the icon for your new tablet.
Your tablet data is imported to your new tablet.

Related information
Check for BlackBerry Desktop Software updates, 15 
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Mobile Internet or tethering

About using Mobile Internet to tether your 
smartphone
Depending on your wireless service provider, you can use the Mobile Internet feature to set up your BlackBerry smartphone 
as a modem by connecting it to your computer with a USB cable. This is also known as tethering. Using your smartphone as 
modem allows you to connect to the Internet on your computer when you might not otherwise have access to the Internet. 
This feature isn't available for the BlackBerry® PlayBook™ tablet.

You can use only one smartphone as a modem with your computer at a time. If your smartphone is associated with a 
BlackBerry Enterprise Server, contact your administrator to make sure that the appropriate IT policy is turned on to use this 
feature.

Set up your Mobile Internet settings
Before you can use your BlackBerry smartphone as a modem, you must set up your Mobile Internet settings. You select or 
create a profile that contains the information that your wireless service provider needs to allow the Internet connection. 
Some profiles have been provided but you can also create a new profile.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Tools > Mobile Internet settings.

3. Do one of the following:

• If your wireless service provider appears in the Profile drop-down list, click their profile. In the Profiles Settings 
section, type any required information that isn't included in the profile. For more information, contact your 
wireless service provider.

• If your wireless service provider doesn't appear in the Profile drop-down list, click Add. Type a name for the 
profile. Contact your wireless service provider to determine the information that is required for the profile settings. 
Click OK. Required information can vary for each wireless service provider.

4. Click OK.
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Connect to the Internet using your 
smartphone as a modem
Before you begin: To perform this task, you must first set up your Mobile Internet settings to create a connection profile. 
Depending on your wireless service plan, extra fees might apply.

1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Tools > Start Mobile Internet.

3. Click Connect.

To end the connection, click your Internet connection status. If the BlackBerry Desktop Software is already closed, you can 
also end the connection by clicking the Dial-Up icon in the notification area of the Windows taskbar.
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Certificates for your smartphone

About synchronizing certificates with your 
smartphone
If your BlackBerry smartphone is associated with a BlackBerry Enterprise Server, you can use the certificate 
synchronization tool to download or import certificates to your computer, synchronize certificates between your 
smartphone and your computer, and verify the authenticity and status of certificates. This feature isn't available for the 
BlackBerry® PlayBook™ tablet.

The certificate synchronization tool is designed to access certificate status information and certificate server information 
by requesting the information from certificate authority servers and LDAP, OCSP, and CRL certificate servers, or by 
synchronizing the information between your computer and your smartphone over a USB connection.

Turn on the certificate synchronization tool
Before you can synchronize certificates, you must turn on the certificate synchronization tool in the BlackBerry Desktop 
Software. If you selected the certificate synchronization option when you first started the BlackBerry Desktop Software, the 
certificate synchronization tool is already turned on.

1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Tools > Desktop options.

3. Select the Use certificate synchronization checkbox.

4. Click OK.

Import a certificate from your computer
You can import several certificate file types to your BlackBerry smartphone, including .pfx, .p12, .cer, .der, .crt, .cert, .p7b, 
or .key files.

1. Connect your smartphone to your computer.
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2. In the BlackBerry Desktop Software, click Certificates. If prompted, type the password for your key store login.

3. Click Import certificates.

4. Click a certificate file.

5. Click Open.

Synchronize certificates from your 
computer to your smartphone
1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Certificates. If prompted, type the password for your key store login.

3. Select the checkbox beside one or more certificates.

4. Click Sync Certificates.

To remove a certificate from your smartphone, clear the checkbox beside the certificate. Click Sync Certificates.

View properties or status information for a 
certificate
1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Certificates. If prompted, type the password for your key store login.

3. Click the tab for the type of certificate you want to see.

4. Double-click a certificate.

• To view the certificate's properties, click the Details tab.

• To view the status information, click the Certification Path tab. The Certificate status field displays status 
information for the certificate.

5. Click OK.
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Certificate properties
Depending on the certificate, more properties or fewer properties might appear in the certificate synchronization tool of the 
BlackBerry Desktop Software.

Property Description

Certificate Label This field displays the name of the certificate. By default, the certificate synchronization tool 
displays the name of the certificate subject.

Security Level This field displays the security level of the certificate if the certificate contains a private key.

Email Address This field displays the email address of the certificate subject.

Certificate Source This field displays the name of the certificate server that the certificate is located on or the 
name of the Windows key store on the computer that the certificate is located on.

Serial Number This field displays the certificate serial number in hexadecimal format.

Signature Algorithm This field displays the algorithm that the certificate issuer used to generate the digital 
signature.

Issuer This field displays detailed information about the certificate issuer.

Valid From This field displays the date that the certificate issuer specified as the start date for the 
certificate.

Valid To This field displays the date that the certificate issuer specified as the expiration date for the 
certificate.

Subject This field displays detailed information about the certificate subject.

Public Key This field displays the standard that the public key complies to. Your BlackBerry smartphone 
supports RSA, DSA, Diffie-Hellman, and ECC keys.

Subject Alternative 
Name

This field displays an alternate email address for the certificate, if known.

Authority Information 
Access

This field displays the location of and access method for the OCSP status responders.

Key Usage This field displays approved uses for the public key.
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Property Description

Thumbprint Algorithm This field displays the hash algorithm used to calculate the digital thumbprint of the certificate.

Thumbprint This field displays the digital thumbprint of the certificate. The digital thumbprint is a hash of 
the certificate encoding.

Install a root certificate on your computer
You might not be able to connect to some Wi-Fi networks until you install a root certificate on your BlackBerry smartphone. 
You can install the root certificate on your computer, and then use the BlackBerry Desktop Software to install the root 
certificate on your smartphone. For more information, contact your administrator.

1. Download the root certificate from the certificate authority server to your computer.

2. On your computer, right-click the root certificate.

3. Install the certificate in the Trusted Root Certification Authorities store.

If the root certificate contains multiple certificates, all the certificates are installed on your computer.

To install the root certificate on your smartphone, use the certificate synchronization tool of the BlackBerry Desktop 
Software to synchronize the root certificate from your computer to your smartphone.

Certificate servers

Add, delete, or update a certificate server
1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Certificates tab, in the Servers section, click Configure.

• To add a server, click a server tab. Click Add. Specify the server information.

• To delete a server, click a server tab. Click a server. Click Delete.

• To update a certificate server, click a server tab. Click a server. Click Edit. Change the connection information.

4. Click OK.
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Change the default security level for private keys
1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Certificates tab, in the Private Key Security Levels section, change the default security level for signing keys 
and decryption keys.

4. Click OK.

Turn off automatic initialization of the random number 
generator
By default, each time that you connect your BlackBerry smartphone to your computer and open the BlackBerry Desktop 
Software, the certificate synchronization tool initializes the random number generator on your smartphone. If you turn off 
automatic initialization, your smartphone uses the same starting point each time it generates a random number.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the General tab, clear the Initialize device random number generator checkbox.

4. Click OK.

Change the refresh rate for certificate revocation lists
You can change how often the certificate synchronization tool updates the certificate revocation lists on your BlackBerry 
smartphone.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Certificates tab, in the Servers section, click Configure.

4. On the CRL tab, do any of the following:

• If you want to update the certificate revocation lists on your smartphone every time that you connect your 
smartphone to the BlackBerry Desktop Software or synchronize certificates, set the Update the cached CRL 
servers every <#> hours field to 0.

• If you want to specify a refresh rate, set the Update the cached CRL servers every <#> hours field to a number 
other than 0.

5. Click OK.
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When you synchronize your certificates, the certificate synchronization tool queries the certificate revocation lists in the 
key store cache for the revocation status of the certificates and updates the revocation status on your smartphone if the 
status has changed.

Refresh all certificate revocation lists
1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Certificates tab, in the Servers section, click Configure.

4. On the CRL tab, click Update.

5. Click OK.

Use OCSP or CRL certificate servers to check the 
revocation status of certificates
1. Connect your BlackBerry smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Certificates tab, in the Servers section, click Configure.

4. To use OCSP or CRL certificate servers to check the revocation status of certificates, do one of the following:

• On the OCSP tab, select the Use OCSP checkbox.

• On the CRL tab, select the Use CRL checkbox.

5. To use the connection information in the certificate extension section of a certificate to check the revocation status of 
a certificate, do one of the following:

• On the OCSP tab, select the Use OCSP certificate extensions checkbox.

• On the CRL tab, select the Use CRL certificate extensions checkbox.

6. To use any certificate servers that you add to the certificate synchronization tool to check the revocation status of a 
certificate, do one of the following:

• On the OCSP tab, select the Use specified OCSP servers checkbox.

• On the CRL tab, select the Use specified CRL servers checkbox.

7. Click OK.
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Download certificates for your contacts automatically
Before you begin: Before you perform this task, contact your administrator as this task can result in reduced computer or 
network performance. You'll also need to verify that you have added an LDAP certificate server to the certificate 
synchronization tool of the BlackBerry Desktop Software.

If you choose to perform this task, when you access the Certificates section in the BlackBerry Desktop Software, the 
certificate synchronization tool queries all associated LDAP certificate servers and retrieves certificates for contacts in the 
contact list on your BlackBerry smartphone.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Certificates tab, in the Servers section, click Configure.

4. On the LDAP tab, select the Use the contacts data on my device when searching LDAP servers checkbox.

5. Click OK.

Troubleshooting: Certificates

A certificate doesn't appear in the certificate list
Using your Internet browser, verify that the certificate is installed on your computer. See the online help for your Internet 
browser for information about how to view the certificates that are installed on your computer.
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Files

About copying files
You can copy files and folders between your BlackBerry smartphone or BlackBerry PlayBook tablet and your computer. 
When you connect your smartphone or tablet to the BlackBerry Desktop Software, you can access its storage drive and 
drag and drop files between your computer's desktop or Windows Explorer.

After you copy the files onto your smartphone or tablet, you can reorganize your files by moving them to a new or an existing 
folder.

You can also copy encrypted files between your smartphone and your computer. If you're copying encrypted files from a 
smartphone that has encryption turned on, you must keep encryption turned on to view and copy the files successfully. If 
you turn off encryption for your smartphone and need to open or copy an encrypted file, you need to turn encryption on 
again. If a file from your media card is encrypted, a lock appears beside the file icon. A file might be encrypted even if a lock 
doesn't appear beside it. To check whether a file is encrypted, see the encryption settings on your smartphone.

Encrypted files take longer to copy than non-encrypted files, as your smartphone is actively encrypting and decrypting files 
before they are copied.

Encrypted files aren't supported on the tablet.

Copy files from your computer to your 
smartphone or tablet
Before you begin: Before you copy encrypted files, verify that encryption is turned on for your BlackBerry smartphone. 
Encrypted media files aren't supported on the BlackBerry PlayBook tablet.

1. Connect your smartphone or tablet to your computer.

2. In the BlackBerry Desktop Software, click Files.

3. If necessary, click Get Started.

4. In the BlackBerry icon drop-down list, click the location that you're copying files to.

5. On your computer, navigate to the files or folders that you want to copy.

6. Drag one or more files or folders to the Files screen.
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Copy files from your smartphone or tablet 
to your computer
Before you begin: Before you copy encrypted files, verify that encryption is turned on for your BlackBerry smartphone. 
Encrypted media files aren't supported on the BlackBerry PlayBook tablet.

1. Connect your smartphone or tablet to your computer.

2. In the BlackBerry Desktop Software, click Files.

3. If necessary, click Get Started.

4. In the BlackBerry icon drop-down list, click the location that you're copying files from.

5. Navigate to the files that you want to copy.

6. Drag one or more files or folders to your computer's desktop or Windows Explorer.

Troubleshooting: Files

My encrypted files didn't copy
If you're unable to view or copy encrypted files between your BlackBerry smartphone and your computer, try the following:

• Verify that encryption is still turned on for your smartphone and your media card.
• Verify that your smartphone isn't locked.
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Media

About media files
You can manage your media files—music, pictures, and videos—between your BlackBerry smartphone and your 
computer, or your BlackBerry PlayBook tablet and your computer.

You can import your pictures and videos from your smartphone or tablet to your computer, and you can synchronize the 
following items from your computer to your smartphone or tablet:

• Your music, organized by playlists, artists, albums, genres, or individual songs from your iTunes library or Windows 
Media Player library

• Your podcasts and other audio files that are in a playlist in your music application
• Your pictures and videos

About encrypted media files
You can now synchronize and import encrypted media files from your BlackBerry smartphone. Encrypted media files aren't 
supported on the BlackBerry PlayBook tablet.

If you're synchronizing or importing encrypted media files from a smartphone that has encryption turned on, you must 
keep encryption turned on to continue using the BlackBerry Desktop Software. If you turn off encryption and want to 
continue using the media features, you need to delete encrypted media from your smartphone.

If your smartphone has built-in media storage that is smaller than 128 MB, you can import encrypted media to your 
computer, but you'll need to use the files feature to copy files from your computer to your smartphone.
Related information
Delete media files from your smartphone or tablet, 56
Copy files from your computer to your smartphone or tablet, 47 
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Supported media file formats
Media type Supported file types

Music File extensions:

• .wav
• .wma
• .mp3
• .m4a
• .aac

Audio files that contain digital rights management (DRM) technologies are not 
supported. If you purchase songs from the iTunes Store, only iTunes Plus 
versions are supported in the BlackBerry Desktop Software.

Pictures File extensions:

• .bmp
• .jpg
• .gif
• .png

Videos File extensions:

• .mpeg
• .mp4
• .3gp
• .mov
• .avi
• .wmv
• .m4v
• .mp2
• .mpg

File formats:

• AVC1
• DivX
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Media type Supported file types

• H.263
• H.264
• MPEG
• MPEG-4
• WMV (8, 9 10)
• Xvid

Audio formats:

• AAC
• AMR
• PCM

Only mono and stereo videos are supported. Other video formats might be 
supported if the applicable codecs are installed.

If you have an AC3 filter installed on your computer, the BlackBerry Desktop 
Software transcodes videos with AC3 audio to AAC format.

Synchronize your music from your 
computer to your smartphone or tablet
Before you begin: To perform this task with your BlackBerry smartphone if encryption is turned off, you must turn on mass 
storage mode. To perform this task with a BlackBerry PlayBook tablet, you must turn on file sharing. You can't synchronize 
encrypted music to your tablet.

You can choose to synchronize specific songs, collections of music such as your playlists, or a random selection of songs 
from your iTunes or Windows Media Player music library. The amount of music you can synchronize depends on the 
amount of storage that is available on your smartphone or tablet for storing music files.

1. Connect your device to your computer.

2. In the BlackBerry Desktop Software, click Music.

3. If necessary, select your music source from the drop-down list and click Get Started.

4. In the drop-down list, select one of the following:

• To synchronize your complete music library, click Sync All Music.

• To select specific songs to synchronize, click Sync Individual Songs. Select the checkbox beside one or more 
songs.
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 • To synchronize a specific playlist or synchronize songs by artist, album, or genre, click Sync Music Collections. If 
you don't see a specific type of music collection, click  and select the collection you want to view. Select the 
checkbox beside one or more music collections. To synchronize a random selection of your songs in addition to 
the collections of music you selected, click Random Music.

5. Click Sync Music.

To view your playlists on your device, click the Media icon or Music icon. Your songs that aren't in a playlist appear together 
in the Music playlist or in their Artists, Albums, or Genres collections.
Related information
Stop synchronizing your music from your computer to your smartphone or tablet, 56

Synchronize your pictures from your 
computer to your smartphone or tablet
Before you begin: You cannot synchronize encrypted pictures to your BlackBerry PlayBook tablet.

By default, pictures are synchronized to your BlackBerry smartphone or tablet at their original size.

1. Connect your smartphone or tablet to your computer.

2. In the BlackBerry Desktop Software, click Pictures.

3. If necessary, click Get Started.

4. On the Computer Pictures tab, do one of the following:

• To synchronize all the pictures within a folder, select the checkbox below one or more folders.

• To synchronize all the pictures within a folder that isn't listed, drag and drop the folder from your computer into 
the Sync pictures from your computer to your device pane, or click Add folder, browse to the folder, and click 
OK. Select the checkbox below the newly added folder.

• To synchronize individual pictures, highlight the folder that contains your pictures. Select the checkbox below one 
or more pictures.

5. If you want to reduce the size of the pictures when they synchronize to your smartphone, click Optimize.

6. Click Sync Pictures.

Pictures that you synchronize from your computer to your smartphone or tablet are located in the Media application. If you 
selected a folder that contains subfolders on your computer, the subfolders also appear on your smartphone or tablet.
Related information
Import your pictures from your smartphone or tablet to your computer, 53
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Synchronize your videos from your 
computer to your smartphone or tablet
Before you begin: You cannot synchronize encrypted videos to your BlackBerry PlayBook tablet.

1. Connect your BlackBerry smartphone or tablet to your computer.

2. In the BlackBerry Desktop Software, click Videos.

3. If necessary, click Get Started.

4. On the Computer Videos tab, do one of the following:

• To synchronize all the videos within a folder, select the checkbox below one or more folders.

• To synchronize all the videos within a folder that isn't listed, drag and drop the folder from your computer into the 
Sync videos from your computer to your device pane, or click Add folder, browse to the folder, and click OK. 
Select the checkbox below the newly added folder.

• To synchronize individual videos, highlight the folder that contains your videos. Select the checkbox below one or 
more videos.

5. If you want to convert the videos for better viewing and storing on your smartphone or tablet, select the Convert 
videos checkbox.

6. Click Sync Videos.

Videos that are synchronized from your computer are located in the Media application on your smartphone or tablet.
Related information
Import your videos from your smartphone or tablet to your computer, 54

Import your pictures from your smartphone 
or tablet to your computer
When you connect your BlackBerry smartphone or BlackBerry PlayBook tablet to your computer, you can import pictures 
that are on your smartphone or tablet. You can't import encrypted pictures from your tablet.

If your smartphone is running BlackBerry 6 or later or if you are importing pictures from your tablet, by default, the 
BlackBerry Desktop Software imports pictures taken using the camera on your device. To also import other pictures from 
your device that you didn't take using the camera, you can change your media settings.
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1. Connect your smartphone or tablet to your computer.

2. If available, to change the default setting and make all pictures on your device available for import, in the BlackBerry 
Desktop Software, click Device > Device options. On the Media tab, clear the Only show pictures taken by the 
device camera checkbox.

3. In the BlackBerry Desktop Software, click Pictures.

4. If necessary, click Get Started.

5. On the Device Pictures tab, do one of the following:

• To import only pictures that are new since your last import, verify that the BlackBerry Desktop Software selected 
your latest pictures.

• To import all your pictures, including pictures that have been imported previously, select the Show imported 
pictures checkbox. Click Check all.

• To import individual pictures, click Clear all. Select the checkbox below each picture you want to import.

6. To change the folder on your computer that your pictures are imported to for the connected device, click Change 
import folder. Select the new folder. Click OK.

7. Click Import Pictures.

Related information
Synchronize your pictures from your computer to your smartphone or tablet, 52 
Import your videos from your smartphone or tablet to your computer, 54
Change your import folder for pictures and videos, 55

Import your videos from your smartphone 
or tablet to your computer
When you connect your BlackBerry smartphone or BlackBerry PlayBook tablet to your computer, you can import videos 
that are on your smartphone or tablet. You can't import encrypted videos from your tablet.

If you are importing videos from your tablet, by default, the BlackBerry Desktop Software imports all of the videos taken 
using the camera on your tablet. To also import other videos from your tablet that you didn't take using the camera, you 
can change your media settings.

1. Connect your smartphone or tablet to your computer.

2. If available, to change the default setting and make all videos on your tablet available for import, in the BlackBerry 
Desktop Software, click Device > Device options. On the Media tab, clear the Only show videos taken by the device 
camera checkbox.

3. In the BlackBerry Desktop Software, click Videos.

4. If necessary, click Get Started.

5. On the Device Videos tab, do one of the following:
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• To import only videos that are new since your last import, verify that the BlackBerry Desktop Software selected 
your latest videos.

• To import all your videos, including videos that have been imported previously, select the Show imported videos 
checkbox. Click Check all.

• To import individual videos, click Clear all. Select the checkbox below each video you want to import.

6. To change the folder on your computer that your videos are imported to for the connected device, click Change 
import folder. Select a new folder. Click OK.

7. Click Import Videos.

Related information
Synchronize your videos from your computer to your smartphone or tablet, 53 
Import your pictures from your smartphone or tablet to your computer, 53 
Change your import folder for pictures and videos, 55

Change your import folder for pictures and 
videos
You can change the folder on your computer that contains your pictures and videos that you import from your BlackBerry 
smartphone or BlackBerry PlayBook tablet.

1. Connect your smartphone or tablet to your computer.

2. In the BlackBerry Desktop Software, click Pictures or Videos.

3. Click the Device Pictures or Device Videos tab.

4. Click Change import folder.

5. Browse to a new folder.

6. Click OK.

Note: You cannot select a root folder or a system folder.

Related information
Import your pictures from your smartphone or tablet to your computer, 53 
Import your videos from your smartphone or tablet to your computer, 54 
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Stop synchronizing your music from your 
computer to your smartphone or tablet
When you stop synchronizing music from your computer to your BlackBerry smartphone or BlackBerry PlayBook tablet, 
your songs, playlists, and other music collections are removed from your smartphone or tablet, but not from your computer.

1. Connect your device to your computer.

2. In the BlackBerry Desktop Software, click Music.

3. Do any of the following:

• To stop synchronizing an individual song or a collection of music with your device, clear the checkbox beside the 
song, playlist, artist, album, or genre of music that you don't want to synchronize.

• To stop synchronizing all of your music with your smartphone or tablet, in the drop-down list, click either Sync 
Music Collections or Sync Individual Songs. Verify that of the checkboxes beside all of the music are cleared.

4. Click Sync Music.

If you don't want your music to be synchronized each time your device is connected, in the drop-down list, click Don't Sync 
Music. The BlackBerry Desktop Software does not remove your songs and music collections from your smartphone or 
tablet.

Related information
Synchronize your music from your computer to your smartphone or tablet, 51 

Delete media files from your smartphone or 
tablet
You can delete the media files that you synchronized from your computer to your BlackBerry smartphone or BlackBerry 
PlayBook tablet using the BlackBerry Desktop Software. You can also set the BlackBerry Desktop Software to automatically 
delete your media files from your smartphone or tablet after you import the media files to your computer.

1. Connect your smartphone or tablet to your computer.

2. In the BlackBerry Desktop Software, click Device > Device options.

3. On the Media tab, do any of the following:
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• To delete media files from your smartphone or tablet, in the Transferring Media to My Device section, click 
Delete all media.

• To automatically delete media files from your smartphone or tablet after you import them, in the Importing Media 
from My Device section, from the After importing media files drop-down list, select Delete files on my device.

4. Click OK.

Change the music source you want to 
synchronize from your computer to your 
smartphone or tablet
1. Connect your BlackBerry smartphone or BlackBerry PlayBook tablet to your computer.

2. In the BlackBerry Desktop Software, click Device > Device Options.

3. Click the Media tab.

4. In the Transferring Media to My Computer section, from the Music source drop-down list, select the music source 
you want to sync to your smartphone or tablet.

5. Click OK.

Troubleshooting: Media

Some of my media files didn't synchronize to my 
smartphone or tablet
Try the following actions:

• Verify that your BlackBerry smartphone or BlackBerry PlayBook tablet has enough available storage for your media.
• Verify that your songs don't contain digital rights management (DRM) technologies.
• Verify that your media files are in a supported format.
• If your videos didn't synchronize or import and the video extension is supported, verify that your video or audio codecs 

are supported.
• Verify that mass storage mode for your smartphone or file sharing for your tablet is turned on.

User Guide Media

57 



• Verify that the songs, playlists, or other collections of music that you expected to synchronize are selected in the 
BlackBerry Desktop Software. If you switched from the Sync Individual Song view to the Sync Music Collections view, 
individual songs that don't belong to selected collections are not synchronized to your device. Similarly, playlists and 
other music collections that you selected in the Sync Music Collections view are not synchronized with your device if 
you switch to the Sync Individual Song view.

I can't synchronize my video that uses the AC3 audio 
format to my smartphone or tablet
The BlackBerry Desktop Software does not support videos with the AC3 audio format.

You can install an AC3 filter on to your computer to convert a video that uses the AC3 audio format to the AAC audio format. 
You can then synchronize the video with your BlackBerry smartphone or BlackBerry PlayBook tablet.

1. Download and install an AC3 filter from the Internet on your computer.
2. After the AC3 filter installation is complete, in the BlackBerry Desktop Software, click Videos.
3. To detect the AC3 filter, click  to refresh the BlackBerry Desktop Software.

4. Select the videos that you want to synchronize.
5. Select the Convert videos checkbox.
6. Click Sync Videos.

My smartphone does not recognize my media card
Try the following actions:

• Verify that your media card is inserted in your BlackBerry smartphone correctly. For more information about inserting a 
media card into your smartphone, see the printed documentation that came with your smartphone.

• On your smartphone, in your media card options, if there is a message to format your media card, disconnect your 
smartphone from your computer. Turn off mass storage mode or MTP. Format the media card. Turn on mass storage 
mode or MTP again.

I cannot import album art
You cannot import iTunes album art if iTunes is busy, or if you are creating playlists, updating podcasts, or accessing the 
iTunes Store.

Close any open dialog boxes and finish any iTunes tasks and try importing album art again. On the Media menu, click 
Refresh iTunes album art.
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A picture folder on my computer isn't recognized
If you are trying to synchronize pictures from a specific folder on your computer to your BlackBerry smartphone or 
BlackBerry PlayBook tablet, the folder might appear dimmed in one of the following situations:

• The folder on your computer is deleted
• The folder on your computer is renamed
• The folder on your computer is on a network drive or USB drive that it is disconnected

Try to correct any of these issues and synchronize again, or select another folder.

My encrypted media files didn't synchronize or import
If you're unable to synchronize or import encrypted media files between your BlackBerry smartphone and your computer, 
try the following:

• Verify that encryption is still turned on for your smartphone and your media card.
• Verify that your smartphone isn't locked.

Error messages

Exceeded available storage
This message appears when there isn't enough storage on your media card or BlackBerry smartphone or your BlackBerry 
PlayBook tablet for your media files that you selected to synchronize.

Try the following actions:

• Consider using a higher capacity media card for your smartphone.
• Select fewer songs or videos to synchronize.
• Transfer media files that are on your smartphone to a media card.
• In the BlackBerry Desktop Software, click Device > Device options. On the Media tab, in the Transferring Media to My 

Device section, decrease the amount of storage that is kept free for files other than your media files. Note that if you're 
using a tablet, you need to keep at least 100 MB of storage space free.
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Wi-Fi music sync

About Wi-Fi music sync
You can use Wi-Fi music sync on your BlackBerry smartphone to browse songs by artists, playlists, albums, and genres that 
are in your Windows Media Player library or iTunes library on your computer. This feature isn't available for the BlackBerry 
PlayBook tablet.

You can select music that you want to download to your smartphone, and when your smartphone is within range of your Wi-
Fi network or when you connect your smartphone to your computer with a USB cable, the music is downloaded to your 
smartphone. You can also create and change playlists and synchronize these playlists from your smartphone to your 
computer.

Music from your computer is integrated in the Music application on your smartphone. These songs appear dimmed if they 
haven't yet been downloaded to your smartphone. Within the Music application on your smartphone, your Wi-Fi Music 
Sync list displays the status of your music, such as pending or downloaded, as well as the status of your connection with 
the BlackBerry Desktop Software.

Your smartphone can only be connected with one computer at a time when using Wi-Fi music sync.

Related information
Prerequisites: Wi-Fi music sync, 60

Prerequisites: Wi-Fi music sync
Your BlackBerry smartphone must be running BlackBerry 6 or higher.

If you want to use a Wi-Fi connection, verify the following requirements:

• Your smartphone and your computer that has the BlackBerry Desktop Software installed on it must be connected to the 
same network.

• The Wi-Fi connection for your smartphone must be turned on.
• The Wi-Fi router for your computer that is associated with your smartphone must be turned on.
• Your computer must be connected to your Wi-Fi router. If your computer uses a wired connection instead of Wi-Fi 

technology, it must be connected to the same network router.
• If your smartphone is associated with a BlackBerry Enterprise Server, the IT policies on your smartphone must allow Wi-

Fi connections. For more information, contact your administrator.

Related information
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About Wi-Fi music sync, 60 

Install Wi-Fi music sync on your 
smartphone
If you didn't install Wi-Fi music sync when you added your BlackBerry smartphone to the BlackBerry Desktop Software, you 
can install Wi-Fi music sync using the following steps.

1. Connect your smartphone to your computer.

2. In the BlackBerry Desktop Software, click Media > Wi-Fi music sync > Turn wireless sync on > Close.

3. Click Music to synchronize the songs on your computer with your smartphone. The first time that you do this for Wi-Fi 
music sync, you must keep your smartphone connected to your computer with a USB cable.

Your Wi-Fi connection status and any other connectivity updates for Wi-Fi music sync appear at the bottom of the 
BlackBerry Desktop Software screen.
Related information
Wi-Fi music sync isn't working as expected, 64

Connect to a Wi-Fi network on your 
smartphone
For more information about connecting your BlackBerry smartphone to a Wi-Fi network, see the help on your smartphone.

1. On your smartphone, on the home screen, click the top of the screen, or click the Manage Connections icon.

2. Click Wi-Fi Network.

3. If you want to connect to a public hotspot or to a Wi-Fi network that doesn't require authentication, select the Show 
Open networks only checkbox.

4. Click the Wi-Fi network that you want to connect to.

5. If the Wi-Fi network requires authentication, type a password for the network.

The name of the Wi-Fi network appears at the top of the home screen.
Related information
I cannot connect to a Wi-Fi network, 64
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Download a song to your smartphone that 
is on your computer
If a song or playlist is on your computer but hasn't been downloaded to your BlackBerry smartphone, it appears dimmed in 
the Music application.

1. On your smartphone, on the home screen, click the Media icon > Music icon.

2. Find and click a song or playlist that is dimmed.

The song or playlist album is added to your Wi-Fi Music Sync list as pending and is downloaded to your smartphone when 
you're within range of your Wi-Fi connection or when you connect your smartphone to your computer with a USB cable.
Related information
Wi-Fi music sync isn't working as expected, 64
About Wi-Fi music sync, 60 
Prerequisites: Wi-Fi music sync, 60 

Stream your music on your smartphone
You can listen to songs that haven't been downloaded to your BlackBerry smartphone yet.

1. On your smartphone, on the home screen, click the Media icon > Music icon.

2. Highlight a dimmed song that hasn't been downloaded yet.

3. Press the Menu key > Stream to listen to the song.

Related information
About Wi-Fi music sync, 60 
Prerequisites: Wi-Fi music sync, 60 
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Show or hide the music that is on your 
computer
You can hide the music from your computer that hasn't been downloaded to your BlackBerry smartphone so that it doesn't 
appear in the Music application on your smartphone. If you want a complete view of all your available music, you can show 
the music from your computer again.

1. On your smartphone, on the home screen, click the Media icon > Music icon.

2. Press the Menu key > Show Home Music or Hide Home Music.

Related information
About Wi-Fi music sync, 60 
Prerequisites: Wi-Fi music sync, 60 

Clear your download history
You can clear the list of songs from your Wi-Fi Music Sync list that you have downloaded from your computer to your 
BlackBerry smartphone or that are waiting to be downloaded.

1. On your smartphone, on the home screen, click the Media icon > Music icon.

2. Click Wi-Fi Music Sync.

3. Press the Menu key > Clear All.

4. If necessary, clear the Clear only finished downloads checkbox.

5. Click Clear All.

Troubleshooting: Wi-Fi music sync
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I cannot connect to a Wi-Fi network
Depending on your BlackBerry smartphone model, the Wi-Fi feature might not be supported.

Try the following actions:

• Verify that you have turned on the connection to the Wi-Fi network.

• Verify that you're in a Wi-Fi coverage area.

• If the Wi-Fi network doesn't appear in the Set Up Wi-Fi application, it might be hidden. If you know the network name, 
connect to the Wi-Fi network manually.

• In the Set Up Wi-Fi application, verify that the options for the Wi-Fi network are correct.

• If you switched Wi-Fi networks manually, switch to another Wi-Fi network or set your BlackBerry smartphone to scan for 
available Wi-Fi networks.

• If your wireless service provider supports UMA, verify that your connection preference isn't set to Mobile Network Only.

• If your email account uses a BlackBerry Enterprise Server, your smartphone might prevent you from connecting to 
certain wireless access points. For more information, contact your administrator.

• If you're using the Push Button Setup method, verify that the access point is enabled with Wi-Fi Protected Setup, and 
that it has been set to send its profile. Verify that another smartphone isn't also attempting to connect at the same time, 
and that not more than one access point within range is in this mode.

• If you use PEAP, EAP-TLS, EAP-FAST, EAP-TTLS, or EAP-SIM to connect to a Wi-Fi network, verify that you have 
installed the root certificate for the certificate authority server that created the certificate for the authentication server.

• If you use EAP-TLS to connect to a Wi-Fi network, verify that you have added your authentication certificate to your 
smartphone.

Related information
Connect to a Wi-Fi network on your smartphone, 61 

Wi-Fi music sync isn't working as expected
If you're unable to use Wi-Fi music sync to download your music or if you can't view your music from Wi-Fi music sync, try 
the following actions:

• Verify that Wi-Fi music sync is installed correctly. On the home screen of your BlackBerry smartphone, click the Media 
icon > Music icon. At the bottom of the screen, click Wi-Fi music sync. The status should display as connected.

• If a long period of time has passed since you installed the BlackBerry Desktop Software on your computer, your security 
certificates might be expired. Try reinstalling the BlackBerry Desktop Software. To install the latest version, visit 
www.blackberry.com/desktop.

• If you're logged in to a VPN, you must log out of the VPN to use Wi-Fi music sync.

If you're trying to use a Wi-Fi connection, try the following actions:
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• Verify that your Wi-Fi connection on your smartphone is turned on. On the home screen of your smartphone, click the 
connections area at the top of the screen, or click the Manage Connections icon. If the Wi-Fi checkbox is cleared, 
select it.

• If the Wi-Fi connection on your smartphone is turned on and there are still issues, verify that your smartphone is 
connected to the same network that your computer is connected to. Check the connection software on your computer 
to see which network you're connected to. If you're not using a wireless connection on your computer, verify that an 
Ethernet cable is connected to the same router that provides your smartphone with a Wi-Fi connection.

• If you can't download your songs using a Wi-Fi connection, connect your smartphone to your computer with a USB 
cable to download your songs. In some cases, if changes are made to your computer settings or smartphone options, 
you might need to connect your smartphone to your computer with a USB cable before you can use a Wi-Fi connection 
again.

If you think that a network connection might not be established, try the following actions:

• On your smartphone, in the browser, type the following URL: http://<IP address>:4481/mediasync/music. If you're 
prompted, accept the certificate warning. If the webpage displays the text "Wireless music sync", then your 
smartphone is connected to the same network as your computer. If you receive a display error, your smartphone isn't 
connected properly to the same network as your computer or there might be a firewall issue or routing issue.

• If your computer, router, or wireless network has a firewall, verify that ports 4481 and 4482 are open for TCP and UDP, 
and that the BlackBerry Desktop Software is allowed by the firewall. For more information and instructions, see the 
documentation for your firewall software.

• If your router has UDP broadcast, verify that UDP broadcast is turned on. Most routers support this feature and don't 
mention it, but your router might need special configuration. For instructions, see the documentation that came with 
your router.

• Verify that your gateway IP address is the same on both your smartphone and your computer, and that both your 
smartphone and computer IP addresses are on the same subnet.

Related information
Pending songs are not downloaded to my smartphone, 66

Some song details aren't appearing on my smartphone
Wi-Fi music sync updates song details on your BlackBerry smartphone about once every hour, so it might take an hour 
after changes are made to your music library on your computer before all the song details that are in your music application 
appear on your smartphone. If you want the song details to appear before then, in the Wi-Fi Music Sync list on your 
smartphone, press the Menu key and click Sync Now, or connect your smartphone to your computer with a USB cable.

I can't see songs on my smartphone that are from the 
music library on my computer
Try the following:
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• Verify that both the BlackBerry Desktop Software and your iTunes library or Windows Media Player library is open on 
your computer.

• Verify that the correct music library is selected in the BlackBerry Desktop Software. Click Device > Device options. On 
the Media tab, if the correct music library isn't selected, in the Music source drop-down list, click the music library that 
you want to use.

Pending songs are not downloaded to my smartphone
If the songs in your Wi-Fi Music Sync list are pending and aren't being downloaded from your computer to your BlackBerry 
smartphone, try the following actions:

• Verify that your smartphone is within range of the Wi-Fi network that your computer is connected to.
• Verify that your smartphone has enough available storage. Try transferring media files that you have stored on your 

smartphone to a media card.
• Verify that the songs aren't being played on your computer or have not been deleted from your computer.
• Verify that your smartphone is charged. If the battery power level drops below 5 per cent, you cannot download your 

songs.

Related information
Wi-Fi music sync isn't working as expected, 64 
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Legal notice
©2012 Research In Motion Limited. All rights reserved. BlackBerry®, RIM®, Research In Motion®, and related trademarks, 
names, and logos are the property of Research In Motion Limited and are registered and/or used in the U.S. and countries 
around the world.

iTunes is a trademark of Apple Inc. iTunes is not endorsed in any manner by Research In Motion Limited. Bluetooth is a 
trademark of Bluetooth SIG. IBM Lotus Domino and IBM Lotus Notes are trademarks of International Business Machines 
Corporation. Microsoft Exchange, Microsoft Outlook, Windows Media, and Windows Vista are trademarks of Microsoft 
Corporation. Wi-Fi is a trademark of the Wi-Fi Alliance. All other trademarks are the property of their respective owners.

This documentation including all documentation incorporated by reference herein such as documentation provided or 
made available at www.blackberry.com/go/docs is provided or made accessible "AS IS" and "AS AVAILABLE" and without 
condition, endorsement, guarantee, representation, or warranty of any kind by Research In Motion Limited and its affiliated 
companies ("RIM") and RIM assumes no responsibility for any typographical, technical, or other inaccuracies, errors, or 
omissions in this documentation. In order to protect RIM proprietary and confidential information and/or trade secrets, this 
documentation may describe some aspects of RIM technology in generalized terms. RIM reserves the right to periodically 
change information that is contained in this documentation; however, RIM makes no commitment to provide any such 
changes, updates, enhancements, or other additions to this documentation to you in a timely manner or at all.

This documentation might contain references to third-party sources of information, hardware or software, products or 
services including components and content such as content protected by copyright and/or third-party websites 
(collectively the "Third Party Products and Services"). RIM does not control, and is not responsible for, any Third Party 
Products and Services including, without limitation the content, accuracy, copyright compliance, compatibility, 
performance, trustworthiness, legality, decency, links, or any other aspect of Third Party Products and Services. The 
inclusion of a reference to Third Party Products and Services in this documentation does not imply endorsement by RIM of 
the Third Party Products and Services or the third party in any way.

EXCEPT TO THE EXTENT SPECIFICALLY PROHIBITED BY APPLICABLE LAW IN YOUR JURISDICTION, ALL CONDITIONS, 
ENDORSEMENTS, GUARANTEES, REPRESENTATIONS, OR WARRANTIES OF ANY KIND, EXPRESS OR IMPLIED, 
INCLUDING WITHOUT LIMITATION, ANY CONDITIONS, ENDORSEMENTS, GUARANTEES, REPRESENTATIONS OR 
WARRANTIES OF DURABILITY, FITNESS FOR A PARTICULAR PURPOSE OR USE, MERCHANTABILITY, MERCHANTABLE 
QUALITY, NON-INFRINGEMENT, SATISFACTORY QUALITY, OR TITLE, OR ARISING FROM A STATUTE OR CUSTOM OR A 
COURSE OF DEALING OR USAGE OF TRADE, OR RELATED TO THE DOCUMENTATION OR ITS USE, OR PERFORMANCE 
OR NON-PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR ANY THIRD PARTY PRODUCTS AND SERVICES 
REFERENCED HEREIN, ARE HEREBY EXCLUDED. YOU MAY ALSO HAVE OTHER RIGHTS THAT VARY BY STATE OR 
PROVINCE. SOME JURISDICTIONS MAY NOT ALLOW THE EXCLUSION OR LIMITATION OF IMPLIED WARRANTIES AND 
CONDITIONS. TO THE EXTENT PERMITTED BY LAW, ANY IMPLIED WARRANTIES OR CONDITIONS RELATING TO THE 
DOCUMENTATION TO THE EXTENT THEY CANNOT BE EXCLUDED AS SET OUT ABOVE, BUT CAN BE LIMITED, ARE 
HEREBY LIMITED TO NINETY (90) DAYS FROM THE DATE YOU FIRST ACQUIRED THE DOCUMENTATION OR THE ITEM 
THAT IS THE SUBJECT OF THE CLAIM.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, IN NO EVENT SHALL RIM BE 
LIABLE FOR ANY TYPE OF DAMAGES RELATED TO THIS DOCUMENTATION OR ITS USE, OR PERFORMANCE OR NON-
PERFORMANCE OF ANY SOFTWARE, HARDWARE, SERVICE, OR ANY THIRD PARTY PRODUCTS AND SERVICES 
REFERENCED HEREIN INCLUDING WITHOUT LIMITATION ANY OF THE FOLLOWING DAMAGES: DIRECT, 
CONSEQUENTIAL, EXEMPLARY, INCIDENTAL, INDIRECT, SPECIAL, PUNITIVE, OR AGGRAVATED DAMAGES, DAMAGES 
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FOR LOSS OF PROFITS OR REVENUES, FAILURE TO REALIZE ANY EXPECTED SAVINGS, BUSINESS INTERRUPTION, 
LOSS OF BUSINESS INFORMATION, LOSS OF BUSINESS OPPORTUNITY, OR CORRUPTION OR LOSS OF DATA, 
FAILURES TO TRANSMIT OR RECEIVE ANY DATA, PROBLEMS ASSOCIATED WITH ANY APPLICATIONS USED IN 
CONJUNCTION WITH RIM PRODUCTS OR SERVICES, DOWNTIME COSTS, LOSS OF THE USE OF RIM PRODUCTS OR 
SERVICES OR ANY PORTION THEREOF OR OF ANY AIRTIME SERVICES, COST OF SUBSTITUTE GOODS, COSTS OF 
COVER, FACILITIES OR SERVICES, COST OF CAPITAL, OR OTHER SIMILAR PECUNIARY LOSSES, WHETHER OR NOT 
SUCH DAMAGES WERE FORESEEN OR UNFORESEEN, AND EVEN IF RIM HAS BEEN ADVISED OF THE POSSIBILITY OF 
SUCH DAMAGES.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW IN YOUR JURISDICTION, RIM SHALL HAVE NO OTHER 
OBLIGATION, DUTY, OR LIABILITY WHATSOEVER IN CONTRACT, TORT, OR OTHERWISE TO YOU INCLUDING ANY 
LIABILITY FOR NEGLIGENCE OR STRICT LIABILITY.

THE LIMITATIONS, EXCLUSIONS, AND DISCLAIMERS HEREIN SHALL APPLY: (A) IRRESPECTIVE OF THE NATURE OF 
THE CAUSE OF ACTION, DEMAND, OR ACTION BY YOU INCLUDING BUT NOT LIMITED TO BREACH OF CONTRACT, 
NEGLIGENCE, TORT, STRICT LIABILITY OR ANY OTHER LEGAL THEORY AND SHALL SURVIVE A FUNDAMENTAL 
BREACH OR BREACHES OR THE FAILURE OF THE ESSENTIAL PURPOSE OF THIS AGREEMENT OR OF ANY REMEDY 
CONTAINED HEREIN; AND (B) TO RIM AND ITS AFFILIATED COMPANIES, THEIR SUCCESSORS, ASSIGNS, AGENTS, 
SUPPLIERS (INCLUDING AIRTIME SERVICE PROVIDERS), AUTHORIZED RIM DISTRIBUTORS (ALSO INCLUDING AIRTIME 
SERVICE PROVIDERS) AND THEIR RESPECTIVE DIRECTORS, EMPLOYEES, AND INDEPENDENT CONTRACTORS.

IN ADDITION TO THE LIMITATIONS AND EXCLUSIONS SET OUT ABOVE, IN NO EVENT SHALL ANY DIRECTOR, 
EMPLOYEE, AGENT, DISTRIBUTOR, SUPPLIER, INDEPENDENT CONTRACTOR OF RIM OR ANY AFFILIATES OF RIM 
HAVE ANY LIABILITY ARISING FROM OR RELATED TO THE DOCUMENTATION.

Prior to subscribing for, installing, or using any Third Party Products and Services, it is your responsibility to ensure that 
your airtime service provider has agreed to support all of their features. Some airtime service providers might not offer 
Internet browsing functionality with a subscription to the BlackBerry® Internet Service. Check with your service provider for 
availability, roaming arrangements, service plans and features. Installation or use of Third Party Products and Services with 
RIM's products and services may require one or more patent, trademark, copyright, or other licenses in order to avoid 
infringement or violation of third party rights. You are solely responsible for determining whether to use Third Party 
Products and Services and if any third party licenses are required to do so. If required you are responsible for acquiring 
them. You should not install or use Third Party Products and Services until all necessary licenses have been acquired. Any 
Third Party Products and Services that are provided with RIM's products and services are provided as a convenience to you 
and are provided "AS IS" with no express or implied conditions, endorsements, guarantees, representations, or warranties 
of any kind by RIM and RIM assumes no liability whatsoever, in relation thereto. Your use of Third Party Products and 
Services shall be governed by and subject to you agreeing to the terms of separate licenses and other agreements 
applicable thereto with third parties, except to the extent expressly covered by a license or other agreement with RIM.

Certain features outlined in this documentation require a minimum version of BlackBerry Enterprise Server, BlackBerry 
Desktop Software, and/or BlackBerry Device Software.

The terms of use of any RIM product or service are set out in a separate license or other agreement with RIM applicable 
thereto. NOTHING IN THIS DOCUMENTATION IS INTENDED TO SUPERSEDE ANY EXPRESS WRITTEN AGREEMENTS OR 
WARRANTIES PROVIDED BY RIM FOR PORTIONS OF ANY RIM PRODUCT OR SERVICE OTHER THAN THIS 
DOCUMENTATION.
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